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1. Installing Windows CE 6.0 

 

Your host PC System Requirements 

- PC with 933MHz or faster processor, 2GHz recommended 

- Windows 2000 Professional Service Pack4, Windows XP Professional Service Pack2 

- 512MB of RAM, 1GB recommended 

- 118GB of available space required on installation derive 

- DVD-ROM 

I would like to recommend Windows full Update through the web site of Microsoft 

before installing Windows CE 6.0 

▶ Step1 Installing Visual Studio 2005 installing 

▶ Step2 Updating Visual Studio 2005 Service Pack 1 installing 

▶ Step3 Installing Windows CE 6.0 installing 

▶ Step4 Updating .NET Compact framework 2.0 Service Pack 1 installing 

▶ Step5 Updating Windows CE 6.0 Service Pack 1 installing 

▶ Step6 Updating Windows CE qfe 2006 installing 

          WinCEPB60-061231-Product-Update-Rollup-Armv4I.msi 

▶ Step7 Installing Virtual Machine Network Driver installing 

▶ Step8 Updating Windows CE 6.0 R2 installing 

▶ Step9 Updating Windows CE qfe 2007, 2008 installing 

  WinCEPB60-070824-KB940982-COMMON.msi  

  WinCEPB60-071031-KBHELPDOCS-COMMON_ENU.msi  

  WinCEPB60-071231-Product-Update-Rollup-Armv4I.msi  

   WinCEPB60-080131-2008M01-Armv4I.msi  

   WinCEPB60-080229-2008M02-Armv4I.msi  

   WinCEPB60-080331-2008M03-Armv4I.msi  

   WinCEPB60-080430-2008M04-Armv4I.msi  

   WinCEPB60-080531-2008M05-Armv4I.msi  

   WinCEPB60-080630-2008M06-Armv4I.msi  

   WinCEPB60-080731-2008M07-Armv4I.msi  

  WinCEPB60-081231-Product-Update-Rollup-Armv4I.msi  

  WinCEPB60-090131-2009M01-Armv4I.msi  

  WinCEPB60-090228-2009M02-Armv4I.msi  

  WinCEPB60-090331-2009M03-Armv4I.msi  

  WinCEPB60-090430-2009M04-Armv4I.msi  
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2. To setup Environment Windows CE 6.0 

 

Please make new folder “\OSDesigns\MVC100” directory and then, Copy all of files  

MVC100.pbxml BSP in \SRC\WinCE\OSDesigns\MVC100 directory to C:\WINCE600\OSDesigns 

\MVC100 directory on your host PC 

 

 



MV C100 Target Board                                          MVC100 WinCE Guide 

 

 

Copyright 2010 MicroVision Co., Ltd.                                               6 

 

And copy MVC100 BSP in \SRC\WinCE\PLATFORM directory to C:\WINCE600 

\PLATFORM directory on your host PC. 
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Click the “Properties” in C:\WINCE600\PLATFORM 
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Please remove “Read-only” and then click “OK” 

 

 

Execute MVC100.pbxml in C:\WINCE600\OSDesigns\MVC100. 
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This is Windows CE 6.0 included MVC100 BSP 
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Click, Project -> Properties 

 

 

The OS Design Properties Pages window appears on your screen. Select Locale tab and 

click Clear All button. It clears all the language settings in your platform. Now 

select English (United States or your language) 
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Now please uncheck the square boxes Enable KITL (no IMGNOKITL=1) in the Build Options 

Properties in OS Design Properties Pages window and then click OK button. 

 

 

 

 

Please make sure “MVC100 ARMV4I Release” 
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Click Build -> Advanced Build Commands -> Sysgen 

 

 

Sysgen successful  
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After sysgen, you can see Eboot, STEPLDR, NK In C:\WINCE600\OSDesigns\ 

MVC100\RelDir\MVC100_ARMV4I_Release 
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3. The way to make New Project 

 

If you want to start over through New Platform, nothing copy “MVC100.pbxml” 

Please the following window appears on your screen. 

 

On the File menu in the Visual Studio 2005 window, click New -> Project 

 

 

The following window appears on your screen. Click “OK” to continue 
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Click “NEXT” 

 

 

The Board Support Packages (BSPs) window appears on your screen.  

Select MVC100: ARMV4I and then click “Next” 

 

 

Select PDA Device from Available design templates list and then click “Next” 
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Select Mobile Handheld from Available design Variants list and then click “Next” 

 

 

Select the Application & Media you want to include in your platform and then click 

“Next” 

 

 

The Networking & Communications wizard window appears on your screen.  
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Click “Finish” 

 

 

Click “Acknowledge” 

 

 

Done 
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After New Project, you have to add to “Catalog Items” before Sysgen 

(Compile). As under picture, Fill in such as “RAM and ROM File System” and 

then it is easy for you to search.  

 

 

 

 

 

To add to Catalog Items List 

 

 

RAM and ROM File System 

Hive-based Registry  

Binary Rom Image File System  

exFAT File System  

Storage Manager Control Panel Applet  

Transaction-Safe FAT File System  
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Direct3D Mobile  

DirectDraw  

DirectShow Video Capture  

WMV/MPEG-4 Video Codec 

Windows Media Player 

 

 

 

 

 

 

USB Function Driver  

USB Host Support  

USB Human Input Device(HID) Class Driver  

USB HID Keyboard and Mouse  

USB Storage Class Driver  
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OBEX File Brower  

OBEX Inbox  

 

 

 

 

 

SD Bus Driver 

SD Memory 

Mass Storage  

serial  

Windows Embedded CE Test Kit 
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Serial Infrared (SIR)  

 

 



MV C100 Target Board                                          MVC100 WinCE Guide 

 

 

Copyright 2010 MicroVision Co., Ltd.                                               22 

 

4. Download 

 

As I introduced in the document MVC100_Operating.pdf, S5PC100 has in the 

CPU 32KB ROM and 96KB SRAM so that can program without JTAG emulator by 

itself.  

 

Please set up as under picture Boot mode. This is Boot mode which can 

download to mDDR through USB Cable. 

 

        

USB Boot mode                   Back Switch position 

 

 

Run DNW.exe in \Tool\DNW v0.60C 

 

 

DNW 
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On the Configuration menu, click Options to set the UART/USB options. The following 

window appears on your screen. Select Baud Rate and COM Port as shown in figure 

“UART/USB options”, enter the download address as 0x20030000 and then click OK 

button.  

 

 

 

 

On the Serial Port menu, click Connect. Switch ON the reference board and then press 

any key and then install the USB driver in \SRC\Tool\DNW v0.60C driver directory. 
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Done 

 

Connect Power 5V with Board and then USB 2.0 OTG Device with your Host PC to download 

through USB Cable and also RS232 for monitoring. 
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As soon as connect power, PC is aware of USB Driver  

 

 

Installing in CD \TOOL\SMDKC100 USB Driver USB Driver 

 

 

  

Success installed output massage “USB OK” 
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Select USB Port -> Transmit -> Transmit for loading “c100_bl1.uboot.bin” 

 

 

Open in C:\WINCE600\PLATFORM\MVC100\ETC\UMON “c100_bl1.uboot.bin” 
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Select USB Port -> Transmit -> Transmit  for running “Eboot.nb0” 

 

 

Open in C:\WINCE600\OSDesigns\MVC100\RelDir\MVC100_ARMV4I_Release  

“eboot.nb0” 
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As soon as EBOOT.nb0 download is over, the following messages appear in the DNW 

window. Please hit the SPACE BAR key to view. 

 

 

 

Eboot mode 
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Eboot  

----------- Connectivity Settings ------------ 

0) IP address  : [169.254.1.101] � IP setup 

1) Subnet mask : [255.255.255.0] � IP subnet mask 

2) DHCP : [*Enabled] � nothing IP, DHCP working 

3) Program CS8900 MAC address : [00:11:22:33:44:55] � IP MAC Address 

--------- Boot Configuration Section --------- 

4) Reset to factory default configuration � Get default configuration 

5) Startup Action after Boot delay : [Launch Existing OS image from Storage] � Select mode 

whether download or kernel. 

6) Boot delay: 5 seconds � Count time eboot 

R) Read Configuration � To load environment  

W) Write Configuration Right Now � To save environment  

------- Kernel Booting Option Section -------- 

K) KITL Configuration           : [*Enabled] � To setup kitl environment  

I) KITL Connection Mode         : [*Interrupt] � To connect kitl Mode 

C) Force Clean Boot Option      : [*True] � Force delete Hive environment 

H) Hive Clean on Boot-time      : [*False] � delete Hive environment 

P) Format Partition on Boot-time: [*False] � format boot partition 

------------- NAND Flash Section ------------- 

A) Erase All Blocks � All of NAND  

E) Erase Reserved Block(Stepldr+Eboot) � To delete boot position  

F) Format Boot Media for BINFS with BadBlock Marking to Reserved Block � To delete kernel 

N) Nand Information and Dump NAND Flash � To out information from NAND 

------------- Test Section ------------- 

M) mDDR Memory Test � To test SDARM 

U) Register Display � To display, it has already registered  

--------- Download and Launch Section -------- 

S) Switch Boot Device : [*USB_DNW] � Select transmission 

        { Options : Ethernet, USB_Serial, USB_RNDIS, *USB_DNW } 

T) Download Target: [Write to NAND Storage] � Your wants position for programming 

D) Download or Program image(OS image will be launched) � Download key 

L) LAUNCH existing Boot Media image � directly work to NK.bin  
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Select “T” [Write to NAND Storage] 

Select “D” and then download step_mvc100.nb0 

 

 

Select USB Port -> UBOOT -> UBOOT for programming step_mvc100.nb0 

 



MV C100 Target Board                                          MVC100 WinCE Guide 

 

 

Copyright 2010 MicroVision Co., Ltd.                                               31 

 

Select step_mvc100.nb0 and then click “open” 
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Reboot for programming “EBOOT.bin” as it first method  

Select USB Port -> Transmit -> Transmit for loading “c100_bl1.uboot.bin” 

 

 

Open in C:\WINCE600\PLATFORM\MVC100\ETC\UMON “c100_bl1.uboot.bin” 
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Select USB Port -> Transmit -> Transmit for working “Eboot.nb0” 

 

Open in C:\WINCE600\OSDesigns\MVC100\RelDir\MVC100_ARMV4I_Release  

“eboot.nb0” 

 



MV C100 Target Board                                          MVC100 WinCE Guide 

 

 

Copyright 2010 MicroVision Co., Ltd.                                               34 

 

As soon as EBOOT.nb0 download is over, the following messages appear in the DNW 

window. Please hit the SPACE BAR key to view. 

 

 

Select “T” [Write to NAND Storage] 

Select “D” and then download EBOOT.bin 
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Select USB Port -> UBOOT -> UBOOT for programming “EBOOT.bin” 

 

 

Select “EBOOT.bin” and then click “Open” 
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Done 

 

 

NAND was programmed 0x0 STEPLDR.nb0 and 0x2 EBOOT.bin. Now change NAND 

Flash boot mode for programming NK.bin of kernel.  

 

Please setup NAND boot mode. 

 

          

NAND boot mode             Back Reset Switch position 
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As soon as EBOOT.nb0 download is over, the following messages appear in the DNW 

window. Please hit the SPACE BAR key to view. 

 

Select “T” to make sure [Write to NAND Storage] and then select “F” to be 

formatted NK (kernel) area, select “D” for programming NK.bin 
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Select USB Port -> UBOOT -> UBOOT for programming NK.bin  

 

 

Select “NK.bin” and then click “Open”  
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You can make sure after 30 minute 
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5. Application 

 

5.1 To make SDK 

 

You’d like to use Visual Studio 2005 with Application of program. You should make 

SDK. Please the following window appears on your screen  

 

Project menu, -> Click “Add New SDK” 

 
 

Fill in your wants name and then click “OK” 
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Build menu, -> Click “Build All SDKs” 

 
 

 

 

Done 
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After build, you can see SDK position as under picture  

 

 

 

Install SDK.mis in C:\WINCE600\OSDesigns\MVC100\SDKs\SDK1\MSI directory  

 

Click “NEXT” 

 

 

Select “Accept” -> Click “NEXT” 
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Click “NEXT” 

 

 

Select “Complete” 

 

 

Click “NEXT” 
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Click “Install” 

 

 

Click “Finish” 
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5.2 To make New Project for Application 

 

Run Visual Studio 2005 

 

 

Click File -> NEW -> Project  

 



MV C100 Target Board                                          MVC100 WinCE Guide 

 

 

Copyright 2010 MicroVision Co., Ltd.                                               46 

 

Select “Smart Device” -> “MFC Smart Device Application” -> Fill in name and then 

click “OK” 

 

 

Click “NEXT” 
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Select “MVC100” Press the button “>” and then click “NEXT” 

 
Select “Dialog based”, “Use MFC in a static library” and then click “NEXT” 
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Click “NEXT” 

 
Select “ActiveX controls” Click “NEXT” 
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Select “Ccamera_testApp” Click”Finish” 

 

 

 
Done 
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5.3 To run the Camera  

 

Connect on the Base Board Camera through Camera Cradle Cable 
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Click “My Device” 

 

 

 

Click “Windows” 

 

 

 

Run “CameraDshowApp” 
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Click “OK” 

 

 

 


